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Introduction to Gmsh

Gmsh is
@ an open source 3D finite element mesh generator
o a CAD engine
@ a post-processing tool
o

available for different distributions (e.g. Windows, Linux, MacOS)
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Introduction to Gmsh

Gmsh is
@ an open source 3D finite element mesh generator
o a CAD engine
@ a post-processing tool
o

available for different distributions (e.g. Windows, Linux, MacOS)

Its design goal is to provide a fast, light and user-friendly meshing tool with parametric input and
advanced visualization capabilities. J
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A little more about Gmsh

Gmsh can be used
e through a GUI

@ using a command line through Gmsh’s own scripting language
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A little more about Gmsh

Gmsh can be used
e through a GUI

@ using a command line through Gmsh’s own scripting language

In today’s session, we shall learn a method with a combination of both. )
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A little more about Gmsh

The geometry of any given problem is represented via a file “<filename>.geo”. Such files can
be created:

@ using a text editor like vim.
o through the GUI

n Adhikari (UiO) Mesh generation with Gmsh PTetra Workshop 5/23



A little more about Gmsh

The geometry of any given problem is represented via a file “<filename>.geo”. Such files can
be created:

@ using a text editor like vim.
o through the GUI

To open the Gmsh GUI J

#> gmsh
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A little more about Gmsh

The geometry of any given problem is represented via a file “<filename>.geo”. Such files can
be created:

@ using a text editor like vim.
o through the GUI

To open the Gmsh GUI J

#> gmsh

To open a . geo file using the Gmsh GUI J

#> gmsh <filename>.geo

Dr. Sayan Adhikari (UiO) Mesh generation with Gmsh PTetra Workshop 5/23



A little more about Gmsh

The geometry of any given problem is represented via a file “<filename>.geo”. Such files can
be created:

@ using a text editor like vim.
o through the GUI

To open the Gmsh GUI
#> gmsh

To open a . geo file using the Gmsh GUI J

#> gmsh <filename>.geo

Note: Remember to activate you conda environment J

#> conda activate ptetra
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A little more about Gmsh

How to write a . geo file?

Use vim/vi/nano or any of your favorite text editor to create a HelloWorld. geo file.
#> vim HelloWorld.geo
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A little more about Gmsh

How to write a . geo file?

Use vim/vi/nano or any of your favorite text editor to create a HelloWorld. geo file.
#> vim HelloWorld.geo

Now, let’s make our own first geometry file! )
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Basic elements of Gmsh

How to define points?

Points are defined as:
Point (id) = {x, y, z, cl};
id: unique id assigned to each element with a specific type
x, vy, z:coordinates of the specific point
c1: mesh element size at this point
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Basic elements of Gmsh

How to define points?

Points are defined as:
Point (id) = {x, y, z, cl};
id: unique id assigned to each element with a specific type
x, vy, z:coordinates of the specific point
c1: mesh element size at this point

Example
Point (1) = {0, O, 0, 0.1};
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Basic elements of Gmsh

How to define points?

Points are defined as:
Point (id) = {x, y, z, cl};
id: unique id assigned to each element with a specific type
x, vy, z:coordinates of the specific point
c1: mesh element size at this point

Example
Point (1) = {0, O, 0, 0.1};

Now, let’s see it in action! J
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Basic elements of Gmsh

Example of a . geo file with 8 points

Point (1) = {0, 0, 0, 0.1};
Point (2) = {1, 0, 0, 0.1};
Point (3) = {0, 1, 0, 0.1};
Point (4) = {0, 0, 1, 0.1};
Point (5) = {0, 1, 1, 0.1};
Point (6) = {1, 0, 1, 0.1};
Point(7) = {1, 1, 0, 0.1};
Point (8) = {1, 1, 1, 0.1}; )
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Basic elements of Gmsh

Points are defined as:

Line (id) = {start, end};
id: unique id assigned to each element with a specific type
start, end: start and end points of a line
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Basic elements of Gmsh

How to define lines?
Points are defined as:
Line (id) = {start, end};
id: unique id assigned to each element with a specific type
start, end: start and end points of a line

Example

Point (1) = {0, 0, 0, 0.1};
Point (2) = {1, 0, 0, 0.1};
Line (1) = {1, 2};
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Basic elements of Gmsh

How to define lines?
Points are defined as:
Line (id) = {start, end};
id: unique id assigned to each element with a specific type
start, end: start and end points of a line

Example

Point (1) = {0, 0, 0, 0.1};
Point (2) = {1, 0, 0, 0.1};
Line (1) = {1, 2};

Now, let’s see it in action!

J
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Basic elements of Gmsh

Example: Eight points connected via lines (Cube)

Point (1) = {0, 0, 0, 0.1};
Point (2) = {1, 0, 0, 0.1};
Point (3) = {0, 1, 0, 0.1};
Point (4) = {0, 0, 1, 0.1};
Point (5) = {0, 1, 1, 0.1};
Point (6) = {1, 0, 1, 0.1};
Point (7) = {1, 1, 0, 0.1};
Point (8) = {1, 1, 1, 0.1};
Line (1) = {5, 3};

Line(2) = {3, 7};

Line(3) = {7, 8};

Line (4) = {8, 5};

Line(5) = {4, 1};

Line(6) = {1, 2};

Line(7) = {2, 6};

Line(8) = {6, 4};

Line (9) = {5, 4};

Line (10) = {8, 6};
Line(11) = {7, 2};
Line(12) = {3, 1};

= =
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Basic elements of Gmsh

Points are defined as:
Circle (id) = {start, center, end};
id: unique id assigned to each element with a specific type
start, end: start and end points of an arc
center: center of the arc/circle
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Basic elements of Gmsh

How to define circles/circular arc?
Points are defined as:
Circle (id) = {start, center, end};
id: unique id assigned to each element with a specific type
start, end: start and end points of an arc
center: center of the arc/circle

Example

Point (1) = {0, 0, 0, 0.1};
Point (2) = {1, 0, 0, 0.1};
Point (3) = {0, 1, 0, 0.1};
Circle(l) = {2, 1, 3};

Dr. Sayan Adhikari (UiO) Mesh generation with Gmsh PTetra Workshop 11/23



Basic elements of Gmsh

How to define circles/circular arc?
Points are defined as:
Circle (id) = {start, center, end};
id: unique id assigned to each element with a specific type
start, end: start and end points of an arc
center: center of the arc/circle

Example

Point (1) = {0, 0, 0, 0.1};
Point (2) = {1, 0, 0, 0.1};
Point (3) = {0, 1, 0, 0.1};
Circle(l) = {2, 1, 3};

Now, let’s see it in action! J
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Setting up a geometry for PTetra

PTetra Workshop Directory

PTetraWorkshop
BLAS-3.10.0
Geometry
Ssphere_0.5R.gE0. .ttt iiiiiinannnnn base . geo file for sphere case
cylinder 0.5R_5L.0€0 cuvrrrrrrenrennnnnnnnnns base . geo file for cylinder case

msh2topo.dat
PTetra.zip
PTetra
README . md
environment.yml
funcs.py

plot.py
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Setting up a geometry for PTetra

Setting up geometry parameters

Open sphere_0.5R.geo using any text editor.
#>vim sphere_0.5R.geo
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Setting up a geometry for PTetra

Setting up geometry parameters

Open sphere_0.5R.geo using any text editor.
#>vim sphere_0.5R.geo

// STEP 1: SET VARIABLES

debye = 0.00690; // Electron debye length for n=lell and T=1000

r = 0.5+«debye; // Inner radius

R = TBD; // Outer radius

TBD; // Resolution on outer boundary
res = TBD; // Resolution on inner boundary

o
(7]
Il
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Setting up a geometry for PTetra

Deciding the system length and local grid resolution

// STEP 1: SET VARIABLES

debye = 0.00690; // Electron debye length for n=lell and T=1000
r = 0.5+«debye; // Inner radius

R = TBD; // Outer radius How to decide such a number??

Res = TBD; // Resolution on outer boundary

res = TBD; // Resolution on inner boundary

y

There is no simple rule. But, the best practice is to consider the system length so big that
ensures the E-field due to the object is zero at the boundary (Dirichlet Boundary).
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Setting up a geometry for PTetra

Deciding the system length and local grid resolution

// STEP 1: SET VARIABLES

debye

res

= 0

r

= 0.00690; // Electron debye length for n=lell and T=1000
.5xdebye; // Inner radius

+10+debye; // Outer radius How to decide such a number??
TBD; // Resolution on outer boundary

TBD; // Resolution on inner boundary

y

Answer: There is no simple rule. But, the best practice is to consider the system length so big that
ensures the E-field due to the object is zero at the boundary (Dirichlet Boundary).
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Setting up a geometry for PTetra

Deciding the system length and local grid resolution

// STEP 1: SET VARIABLES

debye = 0.00690; // Electron debye length for n=lell and T=1000
r = 0.5+debye; // Inner radius

R = r+10xdebye; // Outer radius

What about the local grid resolution??

Res = TBD; // Resolution on outer boundary

res = TBD; // Resolution on inner boundary

The well accepted criterion for PIC simulations in Cartesian meshes: Ax <~ 3\p. For
unstructured mesh, Ax becomes the cell diameter (the largest edge-length of a tetrahedron). The
central idea of such is to avoid finite grid instabilities in PIC simulations.
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Setting up a geometry for PTetra

Deciding the system length and local grid resolution

// STEP 1: SET VARIABLES

debye = 0.00690; // Electron debye length for n=lell and T=1000
r = 0.5+debye; // Inner radius

R = r+10xdebye; // Outer radius

What about the local grid resolution??

Res = 1.5+debye; // Resolution on outer boundary

res = r/5; // Resolution on inner boundary

The well accepted criterion for PIC simulations in Cartesian meshes: Ax <~ 3\p. For
unstructured mesh, Ax becomes the cell diameter (the largest edge-length of a tetrahedron). The
central idea of such is to avoid finite grid instabilities in PIC simulations.
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Setting up a geometry for PTetra

#>gmsh sphere_0.5R.geo

Building geometry Gmsh GUI J
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Setting up a geometry for PTetra

#>gmsh sphere_0.5R.geo

Building geometry Gmsh GUI J

Now, let’s move to the live session J
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Setting up a geometry for PTetra

Few useful things of Gmsh GUI

Made a mistake?? Go to the left panel
Modules
| Geometry
Elementary entities
Physical groups
Reload script
Remove last script command

It will open up a graphical text editor. Delete the last com-
mand and save it.

Edit sSCripf ceeeeiiiiininnnnnnnnn.

| Mesh
|  Solver
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Setting up a geometry for PTetra

Few useful things of Gmsh GUI

Made a mistake?? Go to the left panel
Modules
| Geometry
Elementary entities
Physical groups
Reload script
Remove last script command

It will open up a graphical text editor. Delete the last com-
mand and save it.

Edit script........c..oiiiiiiiiiia,

| Mesh
|  Solver
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Setting up a geometry for PTetra

Few useful things of Gmsh GUI

Made a mistake?? Go to the left panel
Modules
| Geometry
Elementary entities
Physical groups
Reload script
Remove last script command

It will open up a graphical text editor. Delete the last com-
mand and save it.

Edit sSCripf ceeeeiiiiininnnnnnnnn.

| Mesh
|  Solver
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Mesh generation for PTetra

To export/save the Mesh using Gmsh GUI

Go to the Tools menu on the top left corner and click on Options. Then click on Mesh on the
left and open Advanced tab. Check the box named Optimize quality of tetrahedra
with Netgen. Remember to click on Save Options as Defaults before closing Gmsh.

° \ Options - Mesh
2 General g
@& Gmsh File - Window Help Geomet General ‘ Advanced ‘ VISIbI|Ity‘ Aspect‘ Color‘
® ® Solver [v Compute element sizes using point values
oPtlons CHEN Post-pro [~ Compute element sizes using parametric point values
¥ Modules Plug ins 0 Compute element sizes from curvature
» Geometry Visibility [ Extend element sizes from boundary
» Mesh Clipping [ Optimize quality of tetrahedra
» Solver . ‘v Optimize quality of tetrahedra with Netgen
Manipulator :
[ Optimize high-order meshes
Statistics

Message Console
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Mesh generation for PTetra

Steps to generate Mesh using Gmsh GUI
Go to the left panel and click on Mesh
Modules

| Geometry
| Mesh

Define

.............................................................. To generate 2D Mesh.
.............................................................. To generate 3D Mesh.

Inspect
Save

| _Solver
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Mesh generation for PTetra

Steps to generate Mesh using Gmsh GUI

Go to the left panel and click on Mesh
Modules

| Geometry

| Mesh

Define

2D ettt eeeee e et e e e e To generate 2D Mesh.
.............................................................. To generate 3D Mesh.

Inspect
Save

| _Solver
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Mesh generation for PTetra

@ omsh File Tools Window

[ NON ) Options

L Modules Plugins
» Geometry B
B Visibility

) Define Clipping

1D A

[ Manipulator

— 3D
Optimize 3D
(e FLRBEQTE - Message Console
Set order 1
Set order 2

Meshes
[~ Setorder3
[ Hiah-order tools Go to the Tools menu on the top left

i~ Refine by splitting

— Partition . 2 2
Unparition corner and click on Statistics.
Smooth 2D
Recombine 2D
Reclassify 2D
Experimental

Fy
- Reverse
Fy

Statistics

Understanding the quality of

Delete

Inspect
Save
) Solver

Mesh generation with Gmsh PTetra Workshop 19/23



Mesh generation for PTetra

[ ]} Statistics

Geometry‘ Mesh‘ Post-processing

3659 Nodes
134 Points

228 Lines

23627 Triangles

0 Quadrangles

18108 Tetrahedra

0 Hexahedra

0 Prisms
0 Pyramids

0 Trihedra

0.00421802 Time for 1D mesh
W Time for 2D mesh

0.251003 Time for 3D mesh

0.6736 (04314>099' SN Plot XY | aD
0.8509 (0.3444->0.99' Gamma Plot X-Y | 3D
0.8911 (0.4623->0.99' SIGE Plot X-Y | 3D

[~ Compute statistics for visible entities only

Understanding the quality of

Meshes

Go to the Tools menu on the top left
corner and click on Statistics.
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Mesh generation for PTetra

#Elements.

Understanding the quality of
= Meshes

Go to the Tools menu on the top left
corner and click on Statistics.
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Mesh generation for PTetra

File Tools Window

New...
Open... "
Open Recent To export/save the Mesh using
Merge... Gmsh GUI
Watch Pattern... 5
ikl Go to the File menu on the top left
St corner and click on export. The default
R . o
DZT;:e save as option should be “Guess
from Extension (*.x).” Use
Remote & % 9
.msh” extension and choose
Save Mesh Version 2 ASCII when prompts
Save Model Options
Save Options As Default to save. y

Export...
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Mesh generation for PTetra

Edit msh2topo.dat

#>vim msh2topo.dat
Replace the .msh filename.

Sbegin
nfields=0
sphere.msh
Send

Run msh2topo
#>./msh2topo

Rename msh2topo.out

#>mv msh2topo.out object.topo J
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Mesh generation for PTetra

Edit msh2topo.dat

#>vim msh2topo.dat
Replace the .msh filename.

Sbegin
nfields=0
sphere.msh
Send

Run msh2topo
#>./msh2topo

Rename msh2topo.out

#>mv msh2topo.out object.topo J
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Dassault Falcon Aircraft

Stanford Bunny
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Thank you

Mesh generation with Gmsh PTetra Workshop 23/23



	Introduction to Gmsh
	Basic elements of Gmsh
	Setting up a geometry for PTetra
	Mesh generation for PTetra

